Welcome to Xdrivers
Please login or register.

Poll

Miss fire from cold.

any ideas
0 (0%)
advice please
0 (0%)

Total Members Voted: 0

Author Topic: X5M 555bhp  (Read 532 times)

0 Members and 1 Guest are viewing this topic.

December 16, 2017, 08:48:43 PM

bn16mostin

  • Newbie
  • *
  • Posts: 5
  • Country: england
    • View Profile
X5M 555bhp
« on: December 16, 2017, 08:48:43 PM »
Hi guys weve got a 2010 X5M 555bhp which has developed a miss fire usually only from startup when cold. Its been looked at by mechanics and scanned and so far cant find a deffinate fault except they want to send all injectors off for testing and cleaning but im reluctant as i dont feel its the fault. Any ideas would be appreciated.

December 17, 2017, 06:38:22 AM
Reply #1

Alan Gunn

  • Member
  • ****
  • Posts: 631
  • Country: wales
  • Location: Anglesey North Wales
  • Gender: Male
    • View Profile
Re: X5M 555bhp
« Reply #1 on: December 17, 2017, 06:38:22 AM »
What did the scan it with ?.
A m8 who owns a garage did a snap-on scan on a audi v6 TDI for me and it came back with a fault for the coil pack on cylinder 8. :))
Dedicated bmw software is the best way to go.

December 17, 2017, 11:03:50 AM
Reply #2

graemeX5

  • Member
  • *****
  • Posts: 1870
  • Country: gb
  • Location: Hertfordshire
  • Gender: Male
    • View Profile
Re: X5M 555bhp
« Reply #2 on: December 17, 2017, 11:03:50 AM »
Hi bn16

I think another member X5mkal with an X5M had a similar prob and was down to the high pressure fuel bank see thread below, so definitely worth checking.

Although it's probably worth getting it scanned by BMW or an Indy who has the correct diagnostic tool, that will save time and money, at least that way you should have the answer rather than trying different things which can be more costly.

http://xdrivers.co.uk/forum/index.php/topic,14135.msg138292.html#msg138292

Graeme
Current: E70 X5 in Blue, Fiat Abarths 595 Convertible & 500 Convertible :drive:

Previous: E53 X5 4.4i, E88 135i M Sport Convertible, Audi TT Mk1 V6 Roadster, 3 Smarts, 8 Vauxhalls, 4 Fords, 2 Triumphs, 1 Mini & Bikes

December 18, 2017, 03:35:21 PM
Reply #3

IanP

  • Member
  • ***
  • Posts: 411
  • Country: gb
  • X6M
    • View Profile
Re: X5M 555bhp
« Reply #3 on: December 18, 2017, 03:35:21 PM »
Had the same problem with mine, bmw changed an injector, plug and cap. All good now. However they scanned it and said it was ok, I insisted that they kept it for a check and got the senior technician to take it out, and all of a sudden it had a problem. Lots of threads on US sites about injector problems, and they are not cheap.