Welcome to Xdrivers
Please login or register.

Author Topic: So today i got stuck in the mud  (Read 725 times)

0 Members and 1 Guest are viewing this topic.

March 13, 2018, 08:03:43 PM

Mau5matt

  • Newbie
  • *
  • Posts: 14
  • Country: gb
  • Location: Stoke on trent
  • Gender: Male
    • View Profile
So today i got stuck in the mud
« on: March 13, 2018, 08:03:43 PM »
 :blink: as in the title i got good and proper stuck!

But wile i was trying to get out i had 3 warning lights up
.. not like the speed sensor warning wich i have just had to do... this time it was the abs/oragane hand brake and the 4x4 dsc off light (no flat tyre light) as i was trying to get out. Then it would go off but when the wheels started to spin it would light up again as the light came on i went into only in 2wd! And i could not get out  :))


Any ideas what this could be? Is it right or not?
Pervious jap mad... then the kids came...x3 all the way.

March 13, 2018, 08:37:02 PM
Reply #1

Horizon

  • Member
  • *****
  • Posts: 2518
  • Country: gb
  • Location: Bury Lancashire
  • Gender: Male
    • View Profile
Re: So today i got stuck in the mud
« Reply #1 on: March 13, 2018, 08:37:02 PM »
Have the lights gone out now your out of the mud, or have they stayed on?
Mine did the same, the lights came on once whilst driving, once I turned off the car and restarted it again all was well.
Then in December they all came back on again including the airbag light.
Turned out to be a rear wheel sensor had been damaged by corrosion on the driveshaft had pushed the reluctor ring out of shape and made contact with the wheel sensor.
My indie had a hell of a job getting the driveshaft out of the hub as it was rusted in, another member had the same problem
But I had the flat tyre light on as well, so it could be another DSC fault, or even the ABS pump
Best get the fault codes read, maybe that will reveal the problem
2011 Kia Sorento KX3  2.2D 60 Plate Auto in black ( mine )
BMW E83 X3.  3.0d M Sport, 2008 in black ( now gone )
Honda CRV 2.2 d EX SUV 2011 in Silver. ( Wife's )
BMW E93 330i Convertible  Msport  2007.  ( Now sold )
VW Golf 2.0 TDI 140 GT 2010 ( now sold )
Now Sold 55 plate, X5, 3.0 D Sport. Silv

March 14, 2018, 08:22:38 AM
Reply #2

Mau5matt

  • Newbie
  • *
  • Posts: 14
  • Country: gb
  • Location: Stoke on trent
  • Gender: Male
    • View Profile
Re: So today i got stuck in the mud
« Reply #2 on: March 14, 2018, 08:22:38 AM »
It came off in seconds after i stopped trying to get out of the mud. Then it started in 4wd then spun out and the 3 lights came on and back into 2wd. Then seconds after stopping it went off again  :(
Pervious jap mad... then the kids came...x3 all the way.

March 20, 2018, 08:55:44 PM
Reply #3

x3too

  • Newbie
  • *
  • Posts: 1
  • Country: gb
    • View Profile
Re: So today i got stuck in the mud
« Reply #3 on: March 20, 2018, 08:55:44 PM »
I Have had this same problem , started when the snow came about 5 weeks ago . Lights on and then off after a restart , totally random.

Just to say as of today its fixed , 1 .5 hrs labour at my Indy and a £14 plastic cog repair kit from Ebay for the transfer box motor .

March 24, 2018, 09:33:55 AM
Reply #4

Mau5matt

  • Newbie
  • *
  • Posts: 14
  • Country: gb
  • Location: Stoke on trent
  • Gender: Male
    • View Profile
Re: So today i got stuck in the mud
« Reply #4 on: March 24, 2018, 09:33:55 AM »
Has this really sorted it then?

Ave you tried it out in mid/snow?

Have you got a link to the parts?

Cheers for the reply, im gonna get this sorted because what the point have a 4wd that keeps going into 2wd when you need it  :)) :))
Pervious jap mad... then the kids came...x3 all the way.