Welcome to Xdrivers
Please login or register.

Author Topic: E70 4.0d 2012 parkng sensor issues  (Read 360 times)

0 Members and 1 Guest are viewing this topic.

June 24, 2018, 10:45:37 PM

Huxsta

  • Member
  • **
  • Posts: 74
  • Country: gb
    • View Profile
E70 4.0d 2012 parkng sensor issues
« on: June 24, 2018, 10:45:37 PM »
Hi guys. I currently have the problem that when i select reverse the warning comes up that PDC failure and contact bmw for repair. HOW can i check these individually on my drive. Many posts say to put it in reverse and listen but when the engine is running ive got no chance with either the fronts or the rears. I cannot select reverse without the engine running so am i missing a little trick? Has somebody got THE answer i need????

June 25, 2018, 06:49:20 AM
Reply #1

Alan Gunn

  • Member
  • ****
  • Posts: 526
  • Country: wales
  • Location: Anglesey North Wales
  • Gender: Male
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #1 on: June 25, 2018, 06:49:20 AM »
Just turn the ignition on then in reverse.

June 25, 2018, 07:26:38 AM
Reply #2

Huxsta

  • Member
  • **
  • Posts: 74
  • Country: gb
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #2 on: June 25, 2018, 07:26:38 AM »
That doesnt work as the electronics do not allow an auto to be in reverse without the engine running. However,  i completely forgot about the button on the dash. Anyway i just checked and i now know that my centre right rear doesnt click like the other 7.....so how easy is that to change and where is a good place to get one from. Ebay ok?

June 25, 2018, 08:08:52 AM
Reply #3

Alan Gunn

  • Member
  • ****
  • Posts: 526
  • Country: wales
  • Location: Anglesey North Wales
  • Gender: Male
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #3 on: June 25, 2018, 08:08:52 AM »
You have to remove the bumper to replace the sensor.
You can get the sensor on ebay or main dealer up to you.

June 25, 2018, 03:08:44 PM
Reply #4

gmc15

  • Member
  • ***
  • Posts: 310
  • Country: england
  • Location: Durham
  • Gender: Male
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #4 on: June 25, 2018, 03:08:44 PM »
I have the same problem on my 2012 40D. I can't get any of the sensors to work on the front or back. Can't get any of them to click, so not sure what the problem is. Any ideas?
2003 4.6is - now gone :(  xdrive40d now here  :)

June 26, 2018, 06:55:05 PM
Reply #5

Huxsta

  • Member
  • **
  • Posts: 74
  • Country: gb
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #5 on: June 26, 2018, 06:55:05 PM »
Right ive ordered one from a well known selling site, from a power seller so fingers crissed it works as it should. Now my next question is this..... At the moment there is a slight bulge in the top of the rear bumper where it meets the lower tailgate. I understand this to be a broken clip. Part number anybody so i can do it at the same time or do i just ask for a clip for the rear bumper......?

June 26, 2018, 07:52:34 PM
Reply #6

Alan Gunn

  • Member
  • ****
  • Posts: 526
  • Country: wales
  • Location: Anglesey North Wales
  • Gender: Male
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #6 on: June 26, 2018, 07:52:34 PM »
Put the last 7 of your vin number in this site for every part and number in your car.
http://www.realoem.com/

June 26, 2018, 09:50:17 PM
Reply #7

Huxsta

  • Member
  • **
  • Posts: 74
  • Country: gb
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #7 on: June 26, 2018, 09:50:17 PM »
Cheers for that. Other than getting sime spare expanding rivets, it looks like maybe a tab is broken off the main bumper panel as the diagram suggests 4 tabs locate into another part. Oh well out with the builders gorilla glue it is.

June 27, 2018, 11:51:02 AM
Reply #8

Alan Gunn

  • Member
  • ****
  • Posts: 526
  • Country: wales
  • Location: Anglesey North Wales
  • Gender: Male
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #8 on: June 27, 2018, 11:51:02 AM »
Not bad stuff that gorilla glue.
It was the name that put me off at first until i tried some. :D

June 27, 2018, 02:05:38 PM
Reply #9

Ducklakeview

  • Member
  • **
  • Posts: 60
  • Country: gb
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #9 on: June 27, 2018, 02:05:38 PM »
I had a problem with the left inner front on mine - Turned out it was the number plate, I kid you not - The sticky strip had come loose, and allowed the edge to move about, and it was being detected by the sensor as an "obstacle" - New 3M tape and the problem has gone..

Mike
2012 X5 40d - Loving it..
Z4 3.0 - With LOTS of mods  ::)
#TheZedShed

July 03, 2018, 06:25:32 PM
Reply #10

Huxsta

  • Member
  • **
  • Posts: 74
  • Country: gb
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #10 on: July 03, 2018, 06:25:32 PM »
Right update time so to help others when they do a search for the same problem. I ordered a replacement sensor as one didnt click. ( i found i had to bury my ear over the sensor to hear any of them to be honest) Anyway off with the bumper tonight, a quick flick to remove the old and in with the new........ NO different...aarrrgghhhh. Anyway to cut a long story short it turned out that the wiring harness just about 3” from the multiplug had chaffed and cut into and indeed through some wires. I snipped the harness off and removed about 2” of what was damaged and corroded wires. I had to cut that much off to get back to copper looking wire instead of blackened corrosion. A quick solder up to reconnect, some shrink tube and insulation tape and its all as good as new. So i now have a spare sensor when one does break down. Now i can hear all 4 at the back clicking easier than i could before. Happy days.

July 06, 2018, 09:11:42 AM
Reply #11

Waka

  • Member
  • ***
  • Posts: 296
  • Country: 00
  • Location: East Sussex
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #11 on: July 06, 2018, 09:11:42 AM »
Good job, thanks for the update  :)

Was it much work to get the bumper off? Do you know what caused the initial wearing of the wire?
Curr. - E70 4.0D M Sport
Prev. - E53 3.0D Sport Facelift - Estoril Blue

July 07, 2018, 03:42:42 PM
Reply #12

martin33100

  • Member
  • ***
  • Posts: 370
  • Country: gb
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #12 on: July 07, 2018, 03:42:42 PM »
I used a C110 scanner on our 08 E70 and it listed the rear sensor that was at fault.
I don't know if a C110 will work on a LCI 12 plate though.

July 09, 2018, 08:21:42 PM
Reply #13

Huxsta

  • Member
  • **
  • Posts: 74
  • Country: gb
    • View Profile
Re: E70 4.0d 2012 parkng sensor issues
« Reply #13 on: July 09, 2018, 08:21:42 PM »
Sorry for the delay. Bumper was a doddle to get off. Remove reflectors (watch youtube on how to not break them) undo 4 self tapers underneath rear bumper apron, the 2 behind the reflectors. Remove a couple of the use once rivets each side behind the rear wheel and prise the wheel arches slightly to reveal the other 2 self tapers (one each side) and hey presto. As for the chaffing i guess it rubbed on the chassis somehow. I would say thats the first time that the bumper has ever been off the car since it was made in 2011 as the pile of built up dirt from the nooks and crannys was huge lol. Now ive done it once i reckon it would be sat on the floor (old duvet) in under 5 minutes if a sensor does go. What i found was it was VERY hard to hear any of them and that was with my ear pushed right against the bumper with the sensor more or less in my ear. After i recut the wiring and soldered them back together the clicking was much more pronounced on all 4 so i guess the chaffing means a lower resistance and not as good as they are intended.