Welcome to Xdrivers
Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Silverfox58

Pages: [1] 2 3 4 5 6 ... 8
1
General X5 Forum (E53) / Re: Folding mirrors
« on: April 19, 2018, 08:34:54 AM »
Cheers will take look :)

2
General X5 Forum (E53) / Folding mirrors
« on: April 18, 2018, 06:34:37 PM »
Hi all is there a how to to fix folding mirrors that's not on photobucket

3
How-To / Folding mirrors
« on: April 18, 2018, 06:16:14 PM »
Hi all is there a how to to fix folding mirrors that's not on photobucket.

4
General X5 Forum (E53) / Re: Rear suspension
« on: April 03, 2018, 06:24:48 PM »
Ok thanks will keep an eye on it  :beer2:

5
General X5 Forum (E53) / Re: Rear suspension
« on: April 02, 2018, 06:38:44 PM »
Ok cheers henry

6
General X5 Forum (E53) / Re: Rear suspension
« on: April 02, 2018, 06:31:53 PM »
Hi no just drove to the dump

7
General X5 Forum (E53) / Rear suspension
« on: April 02, 2018, 05:21:25 PM »
Hi all
What to the dump yesterday with a load of wood in the car , loaded car but when I started the car the air suspension failure message came on , when to the dump and got rid of the wood , started  car and no warnings,  and hasn't came on again,
Now my question is do I have a rear suspension problem or was there to much weight in the car ???
The drives ok with no problems it's not down on one side , as it's done 125k could the bags be soft and need changing.
Your thoughts please

8
General X5 Forum (E53) / Re: Car won't start
« on: March 22, 2018, 05:05:02 PM »
Hi I've got it running thanks , it was the big plug that gos in the glow plug module,  funny  though as i didn't tuch that ,
I have the carly reader .
Thanks for all your reply and advise well appreciate

9
General X5 Forum (E53) / Re: Car won't start
« on: March 22, 2018, 07:50:53 AM »
Thanks  for your reply,  but  I've  just fitted new glow plugs and a new exhaust manifold?????

10
General X5 Forum (E53) / Car won't start
« on: March 21, 2018, 11:47:55 AM »
Car won't start just get lots  of white smoke it try but not having it
Any ideas

11
General X5 Forum (E53) / Re: HELP PLEASE
« on: March 20, 2018, 05:32:13 PM »
Ok so been looking at the car today and found a puddle of diesel on the floor, humm so check all over and found one of the leak
Pipe T peace broke
So off to bmw's  well they wanted £48 for a set , so I went to a diesel repair place and got on for £5 ,
Anyway  all fitted but still no start , it's trying but I'm just getting  a lot of white smoke and a flat battery  now,
Any thoughts

12
General X5 Forum (E53) / Re: HELP PLEASE
« on: March 19, 2018, 03:01:04 PM »
Ok I have tried or the plugs there all in and it still won't  start  :rant:

Any more ideas I can try,

Also should  I have taken the battery off when taking it all of and on again???

13
General X5 Forum (E53) / Re: HELP PLEASE
« on: March 17, 2018, 07:14:52 PM »
I will have a look tomorrow  but as its pouring down
With snow it might be Monday  now

14
General X5 Forum (E53) / Re: HELP PLEASE
« on: March 17, 2018, 01:09:00 PM »
One on the front and one on the back, I've even sprayed a bit of wd40 just in case sitll nothing

15
General X5 Forum (E53) / Re: HELP PLEASE
« on: March 17, 2018, 12:21:58 PM »
Could I have an air leak that's stopping it from starting????????

Pages: [1] 2 3 4 5 6 ... 8