Welcome to Xdrivers
Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Horizon

Pages: [1] 2 3
1
Other Marques / Well the X3 is going tomorrow.
« on: February 18, 2018, 08:21:47 PM »
I've decided to get shut of my 58 plate E83 X3. I've had it one week shy of 12 months and after having a year of BMW mechanical and electrical problems between the wife's E39 330i Msport  hard top convertible and my X3 , 3.0d Msport I was getting bong paranoid.
The 330i suffered a failed roll over sensor £400
Failed ABS/ DSC pump  £700
Blown Xenon headlight bulb £120
Rear discs and pads £200
Worn suspension bush £100
Two new rear tyres £200
Alloy refurbishment £260
Service and Valet £185
Then she decided she wanted an SUV after a drive home in the snow in a 3 litre RWD car frightened her to death 🙁

So we PX the 330i in for a 2011 Honda CRV , with NAV Btooth, BT streaming USB / iPod , and she loves it.😀😀😀

Now for the X3 3.0 D Msport.
On the way home from purchasing the car I could feel the transmission winding up and lurching, I had preordered tyres, so on they went. £ 400
Then did the thermostat, glowplugs, glowplug controller, swirlflap delete, airfilter  £150
Then the steering would shake after being on the motorway, so identified a sticking calliper. £150
Then fitted a towbar and dedicated electrics £250
Then the dash lit up like a Christmas tree, turned out to be a wheel sensor and reluctor ring, took them ages to get the hub apart and change the ring as it was seized in, new wheel sensor and at the same time faults on the SAS so replaced . £500
Then the flat tyre light was coming on every 10 miles and a smell of hot brakes, turned out to be another sticking brake calliper on the rear this time £150
 Ow the car / steering shakes a bit when under higher than 60 mph braking so guess the discs have suffered with heat because of the sticking calipers.
I went for a blast the other day to discover no boost, turned the ignition off the back on , hasn't done it since
By this time I've lost all confidence in the car,
Noticed a Kia Sorento KX3 2.2 d on Autotrader , 2 miles away.  Already fitted with a tow bar, Btooth USB, Pan roof, leather, air con, reversing sensors , Xenons , self level suspension , etc etc 32,000 miles FSH Keyless entry 7 seats
Full size alloy Spare , auto lights / wipers Voice activation. Heated electric seats, heated folding mirrors
Picking it up tomorrow after tracking and 2 new tyres.
( yes you can fit 2 new tyres, no need for all 4 😀)
I'm expecting some colourfull comments, 😀
But on a car that they offer 7 years warranty on can't be too shabby. And with 70 K less miles on than the X3, I'm hoping for a bit of bong relief 😁








2
General X3 Forum (E83) / E83 3.0d Dash lit up like a Christmas tree .
« on: December 20, 2017, 06:55:15 PM »
I got a call from the wife this afternoon saying thedashboard had lit up like a Christmas tree.
All the warning lights are on, ABS, airbag , 4x4 , yellow tyre pressure indicator, yellow exclamation mark.
I got home from work, turned the ignition on and all was well. After a short drive of 500 yards they all came back on. 😬
Also the electric radiator cooling fan is on permanently as soon as the ignition is turned on.
I've tried the battery disconnect reset and  clearing the codes.
I'm thinking a DSC issue as I'm getting wheel-HR/ right rear 006dA1 . via Carly.
But also AIrbag fault code as well as others.
Car starts ok and have left it on charge.
I hate Cars 😬😬😬😬😬
Any ideas folks, weird about the fan running , sounds like when you stop during a DPF regen.
Edit
Found this relating to HR rear right wheel


Looks like another ABS pump problem, I've just had the E93 one done a few months ago.
Still don't know why fan is running though, hoping an interrupted regen, but it goes off with the ignition.

3
I am thinking of selling my E83 3.0D Msport. After only buying my X3 in February for 8.5K we're thinking of downsizing our fleet. 😀
At present we have got my E83 and the wife's E93 3.0  petrol hard top convertible Msport. 70k miles FSH, ( just serviced 200 miles ago ) professional CCC sat nav, Bluetooth, voice control, CIC 8 button controller heated leather ( black ), its in the indie at the moment having a new ABS pump, so that will have a lifetime warranty from the overhaulers, as this was a common problem with the E9# series.
We don't need two cars as mine is stuck in the garage 6 days a week and only comes out at weekend to tow the caravan ( 4 /5 trips so far this year )
The wife fancies a Kia Sportage / Sorento that will pull the caravan as well as do a a family car. I have a new van, so I plan to use that for my short weekend run around.
We're not sure which car to trade in, or maybe both.
If there is anyone who fancies a E93 3.0 petrol 280 BHP convertible 2007. 70k.,£6500 or the X3 at £6500.
These prices are £250 above trade in prices, so if interested a bargain to be had. ( I'm not going to put no time wasters, it sounds so cheeky 😬)
extra edit E93 could do with a wheel refurb , apart from that they both drive like new.
I'm a regular poster on here , so you can see that I look after and carry out servicing and maintenance to a top level. Not your usual neglected cars that are for sale . 😀









Or my X3 58 plate , 100k miles FSH. which I've fitted a Westfalia detachable tow bar to, converted to HIDS headlights, removed and blanked the Swirl flaps, 11 months MOT on both. Also I've done the heater plugs and controller, gearbox service, new Bosch wipers.New Pagid pads all around, new OSF brake calliper ( was sticking so replaced .New all season / winter tyres.   £6500. Bargain
Edit . Satnav Bluetooth heated seats folding mirrors on fob.


4
General X3 Forum (E83) / E83 X3 squeaking rear brake.
« on: March 20, 2017, 11:54:06 PM »
Just when I thought I outdated have a weekend without having anything to do on the X3 😬
When I got home from work this evening the wife informed me that the X3 had developed a rubbing/ squeak from the OSR wheel whilst she was out in it today.
Whilst moving in slow moving traffic is sounds like the pads are not retracting enough, and are still touching the disc slightly, once you speed up the squeak goes away.
I had noticed a squeak last week when reversing on to our sloped drive, but that was only when applying the brakes in reverse.
I can see the pads are about half worn. Do I pick up set of new pads from ECP, as if I'm stripping down the back brakes wouldn't it be as easy to fit new pads?
Anyone else had this problem and just cleaned everything up applying copper grease where needed.
Or am I just being tight 😁😁😁
Edit.
Couldn't decide if it was the front or rear that was squeaking, so I stripped them all down today. All the pads had at least 3/4 life left in them but noticed no sign of copper slip .
Cleaned everything up with brake cleaning spray, applied copper grease where needed.
Took her for a spin, so far so good.
EDIT 19/06/2017
The squeak came back, so I ordered a full set of Pagid brakepads from ECP £65 with discount code, fitted them on Saturday, squeak has gone away, and hopefully my front rims won't be as badly contaminated with brake dust in the future. ( don't know what make the originals were, but Hyperdust would be a good name for them 😬)

5
No rest for the wicked, I've picked a new Westfalia detachable towbar up this afternoon from PF Jones in Manchester.
I was going to order on line, but thought I would have a ride down to town.
I was going to go for the 7 pin dedicated electrics pack,   Mainly because the 13 pin setup is £165, plus you then have to purchase a 13/7 pin adapter. £10, so the electrics kit comes to £175.
The 7 pin was advertised at £95, so I thought I would then fit duel electrics as we may be looking into getting a caravan. The guy at the shop told me that as the electric socket swing down through the cut out in the bumper both sockets wasn't an option and I should fit a 13 pin socket. And then fit the 7/13 pin adapter.
At this rate the electrics would cost me as much as the towbar !!!!
So I said I would just go for the 7 pin socket.
When he looked at what was in stock he said they had sold out of the 7 pin kits and he would have to give me a 13 pin kit and a 13/7 pin adapter for £95. Result😀
I've started taking the boot apart and it's no small task removing the polystyrene moulding out of the boot well, every panel has to be removed as well as the battery leads and the two alloy load restraint rails too.
As it's a dedicated kit you have to run a cable up to behind the glove box.😬😬😬😬
So tomorrow afternoon may just see the wiring side run in, if I'm lucky.
Once the wiring in then maybe next week I may get to take the bumper off. 😳


6
General X3 Forum (E83) / E83 X3 , 3.0 d EGR Thermostat. ( or not )
« on: March 04, 2017, 08:32:46 PM »
My next job on my recently acquired X3 is to sort out the coolant temperature problem I've got.
The coolant temp is only reaching 67 degrees C
I looked on real OEM and got the part number for the main thermostat, but couldn't find a number for the EGR thermostat, so there only seems to be one used on the BMW 3.0 engine, so I ordered one.
Whilst I had the engine covers off today I could see the top of the EGR cooler.
It wasn't set up the same as all the ones on YouTube, which I had been trawling looking for How To do videos.
I could see an electrical selenoid valve on the top of it, and where the thermostat normally lives in the outgoing coolant pipe, on mine the pipe just goes straight back into the main return hose.
Has anyone come across this system before.
On real OEM there seems to be a vacuum actuator fastened to the incoming port of the cooler.




I may need a couple of golf tees to do a modification, I'm going to fit the main coolant thermostat and monitor the  temperature.
My MPG is shocking at 67 degrees, must be over fueling .

7
General X3 Forum (E83) / E83 Glowplug, faulty
« on: March 03, 2017, 06:40:19 PM »
Looks like I'm not putting my feet up tomorrow 🙁
When I picked the car up I did a scan at the dealers, it showed up 3 faulty glow plugs, managed to get them to knock some money off the price, I've bought a new glow plug controller and a full set of glow plugs.
Also as I'm having to take the inlet manifold off, I'm going to replace the swirlflaps with blanking plugs at the same time.
Unfortunately I looked in the hidden menu and surprise surprise the coolant temperature is only 67 degrees
So I've ordered both thermostats and will be busy next weekend too.😬😬😬

8
General X3 Forum (E83) / Can I fit a square setupon to staggered wheels.
« on: February 22, 2017, 02:58:58 PM »
As there has been several threads about the importance of the equal rolling circumference , I am awaiting delivery of my latest car change.
I've gone for an E83 X3 3.0d Msport. (58 plate )
As the X3 is super sensitive to differences in the rolling circumference between the front and rear axles, and thanks to KKX5's photos of a destroyed transfer case, I'm very conscious  that I need to get my tyres as sorted and straightforward as possible. ( the car has mismatched makes on at the moment , but drives A1 )
I dislike Runflats with a passion, and have always swapped them out for normal tyres, as on my E60 & E93. Easy enough on two wheel drive as there is no transmission wind up to consider.
I was wishing my X3 was a square setup now, but alas I prefer the look of the Msport.😁
I've trawled the net to find star marked non Runflats to no avail. Then I thought, isn't it acceptable to put a square setup of winter tyres on to staggered rims?
So I have found out through alloy wheels direct's site  ( Sid10 really )that my 191m are 8.5jx front and 9.oJx 19 rears.
I downloaded a wheel width calculator from Blackcircles that says what tyre fit what width rims


At the moment I've got 235/45/19 on 8.5" rims on the front, and 255/40/19 on 9.0 " rims on the rear.
Looking at the chart, I would still put 255/40/19 on the rear, and also put 255/40/19 on the 8.5" rims on the front as it says you can put a max width of 255 on an 8.5 rim
Am I correct in my thinking that this would allow me to adapt a square setup with the option of buying 4x matching 255/40/19 's eliminating any chance of a differential in rolling circumference????
I'd be interested for your comments before I pull the trigger 🤔🤔🤔🤔

9
General X3 Forum (E83) / Back in an X ( X3 this time ! )
« on: February 20, 2017, 06:39:31 PM »
 Weve been struggling at home fitting people and things into our impractical cars.
I've got the 3 series hardtop convertible 330i. The wife has a MK2 Audi TT,  Both cars are not 4 person friendly.
Ive had to rely on mates to ferry my bike around if we were going further a field. Trips to the tip were multiple instead of all in one load.
I looked at getting back in an X5, an E70 was my weapon of choice. But I was limited to 2007/57 plate cars, which came with high tax rate £500😬

While I was on my way back from a job in Lancaster today I stopped off to grab a sandwich from a service station, there was a large car lot next door, so to kill 1/2 an hour I strolled around.
Next thing I know I was test driving a 58 plate 3.0d X3 Msport down the road.
Unfortunately the car sales place was an hour from home so I had to leg it back, jump in my car, wife in tow on our way back to Garstang.
We did the deal, deposit paid, private plate paperwork done ( had to tax new car to do the transfer paperwork😬)
We're just waiting for the plates to be processed, they are servicing the X3 and hopefully pick it up next week
Swapped cars and did plates swap for a few hundred quid.
It's got halogen lights so need to find out if HIDS and white side lights are an option.

10
Other Marques / CCC to CIC controller upgrade.
« on: November 24, 2016, 06:33:37 PM »
Just to share a mod that I've just carried out on my E93 3 series vert. Bare with me as adding photos via the images tab on the forum can be tricky and time consuming 😬
I purchased a used CIC controller from EBay £65, I was searching g for a used centre console panel that had the correct CIC cutout. After weeks of requesting the said panel on several breakers sites I realised they were rarer than hens teeth.
Searching g the net I came across a mod where someone had used their old panel and fibre glassed up the original hole. ( the original CCC controller is wider than the CIC controller.)
So I ordered a CIC controller bezel from a 6 series, which has a flange, so making it wider than the standard setup, then with a dremal set about cutting out my old panel elongating the original hole to accommodate the new bezel.
Once the bezel fitted into the panel I was left with a gap down each side , I then with the aid of masking tape covered the top of the bezel and panel. Once secure I mixed some bumper filler and filled in the gaps, the masking tape mimicked the face of the panel, so didn't have filler falling through. Once set I removed the bezel and sanded flush the facia.
I'd ordered a sheet of carbon fibre wrap and a heatgun again off EBay and set about wrapping my console panel.
I took some photos of work in progress.
please note, the CIC controller is said to only work on cars with the software installed after a certain date, and must have the 8 preset buttons on the CIC module in the dash.
I tried the original plug in the new controller first to make sure it worked before I ordered anything else. So if It didn't work I was only £65 in, and could have re sold it.




11
Other Marques / Returning to the BMW fold.
« on: August 01, 2015, 08:32:44 PM »
Well after swapping my 55 plate E53 3.0 d Sport for a 2010 plate Golf GT 140 TD in Nov 2013 , I have today left a deposit on a 58 plate BMW 335i Msport saloon in Colorado blue metallic.
We travelled the 1 hour journey to Leeds to be there for 9am.
I was looking forward to a test drive and checking over my next proposed car, wondering if it would be a good idea to go back to a petrol powered Beemer. I've previously had several petrols before I got my first privately bought diesel, which was the X5.
I sat in the car along with the wife trying to remember how to control the IDrive, pathetic really as I had the IDrive in my E60 530i that I chopped in for the X5.
When the Salesman started the car up to move it outside for our test drive I stood at the back of the car to look for tell tale blue smoke, all was well I thought, then as he pulled away slowly we could hear a slight rattle from the  near side exhaust backbox. Once outside the noise wasn't noticeable, as I've had a bad cat do the same on my old 840 Ci.
I made myself comfortable in the drivers seat, and pulled out into traffic, headed for the M621, once clear of the 50 mph limit on the slip road I pulled into the outside lane and opened the taps. WOW 😀😀😀😀😀
The words shit of a shovel sprang to mind !!!! Once up to speed it was very smooth and quiet.
Once off the motorway we made our way back into Leeds. Along a duel carriageway then back into the 30 mph traffic. A very nice drive indeed , loads of torque  400 NM from 1300 revs right through the Rev range.
Exhaust sound is awesome too😊 suddenly the IDrive bonged and " Low oil level " 😮😮😮
 AlsoWhilst out on the test drive I noticed that it must be colder in Leeds than the North Pole as the outside temp on the cluster was reading -40 !!!!. Another problem I thought.
Then back to the forecourt, they had their own maintenance garage, so he got his mechanic to come out, he said his lad ( spotty oil apprentice had re topped the oil up after running the engine. After topping up he checked the level on the dash gauge which took a few minutes to show the level ???? Was this normal???? Can't believe there is no dipstick, crazy. Then once it registered all was well, apart from the outside temp problem.
I asked to see the service book and all was well. Then I asked how many fobs/ keys there was, he said just the one. He said I'd get one for about £30 😧😧I told him I wasn't buying a car with one key, so I got up and put my coat on, he said he would sort me a spare key, change the temp sensor ( bumper off job ) and put £50 of petrol in the car for when I pick it up.
So on my return home I googled the exhaust rattle on Google and its normal as there is a flap that closes off in the rear backbox when cold started to help with back pressure until the car warms up a bit. So I'm picking it up when all the jobs are sorted.
Hope I've not bought a lemon 😁


13
Other Marques / New Alloys for my MK6 Golf. Notified my insurance!
« on: July 07, 2014, 11:47:26 PM »
Since part exchanging my X5, and down sizing to a MK6 Golf  ( no abuse please >:( )I fancied freshening up the look of my 2.0 GT TDI. I had seen a set of alloys on a car on the net that was the same colour and model as mine. I checked out the website and identified which wheel it was , so thought I'd treat her to some new wheels, and tyres, as it had to go up a size.
I firstly contacted AXA insurance to ask if they were classed as a modification, and if they would have an impact on my premium  or even invalidate my insurance.
A couple of days later they emailed me back to say. " Alloy wheels are an acceptable modification, but if the cost more than £1 K they wouldn't insure me and I would have to cancel my policy."
So a word of warning to prospective alloy wheel purchasers . If thinking of them non OEM alloys,nor maybe some that are different to the ones fitted at the factory, you could be invalidating you insurance, or being asked to pay more by your insurers. :)

14
General X5 Forum (E70) / E70 Recall ???
« on: February 18, 2014, 04:52:29 PM »
Don't know if this is true. I got this info off BMW LAND.

A bit of a heads up to E70 owners.

Don't know an awful lot about this given the Service Manager had only just found out about himself this morning, but worth checking with your local dealer.....

There's evidently a recall for "Propshaft Whiplash".....again, no further detail on what this actually means but evidently if there is a problem then the propshaft is replaced under warranty.

If I find out anymore later today then I'll post an update.

15
Other Marques / BMW Safety Recall. ( fuel filter heater )
« on: December 16, 2013, 04:26:47 PM »
My Stepson has just received a recall notice from BMW for the replacement of the fuel filter heater.
BMW 1/5/7 series X3,X5, X6.
He has a 116d 59 plate , it has the start button / fob system. Will he be able to get the security update done FOC at the same time do you think ?
He never received any info regarding the security update, was that a recall or do they only do it for customers who have their cars serviced at the dealers.?
I guess this recall involves all the E70 and E 71 owners too by the sounds of it.?

Pages: [1] 2 3