Welcome to Xdrivers
Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Alan Gunn

Pages: [1] 2 3 4 5 6 ... 9
1
General X3 Forum (E83) / Re: Brown froth in coolant??
« on: June 27, 2017, 11:30:55 AM »
Looks like it all changed October 2015.
Still if you have not had it 30 days then go back to the dealer and get him to sort it out.

2
General X3 Forum (E83) / Re: Brown froth in coolant??
« on: June 27, 2017, 06:48:50 AM »
If you bought it from a dealer then they have to put it right.
They have to give you 3 months warranty by law so just take it back.

3
General X5 Forum (E53) / Re: Transmission failsafe
« on: June 24, 2017, 06:03:23 AM »
Inside the box I suspect.  :(
Oh well, can't see me diving inside the box !! not at 74 anyway.
Have tried starting in neutral seems to prevent the trans wng, could it be that the selector switch is in need of adjustmment ?

Lez
Have a look at this see if it helps.
http://www.rangerovers.net/forum/6-range-rover-mark-iii-l322/130874-trans-failsafe-prog-error-3c-program-sel-switch-implausible-signal-help-pls.html

4
General X5 Forum (E53) / Re: E53 Door Mirrors - spare wires...
« on: June 23, 2017, 05:23:44 PM »
Not sure but could they be for the auto dimming.

5
Problems / Re: MOT advises?
« on: June 23, 2017, 10:57:47 AM »
I had some play in a ball joint and one of the drop links.
All looked to be getting on in years so i bought new parts fro both sides and got my m8 with a garage to change the lot job done.
Didn't go for top notch parts as i don't do a lot of miles but got the lot from Germany for not a lot and delivered in 3 days.
I think the total inc fitting was around £200.
Car drives so much better now as well.

6
Problems / Re: Engine oil Light flashes at low speeds
« on: June 22, 2017, 10:05:26 AM »
Low oil pressure then.
Might be worth an oil and filter change to see if that makes any difference.
Get the oil pressure tested.
Also it could be a faulty sensor in the sump.

7
Problems / Re: Engine oil Light flashes at low speeds
« on: June 22, 2017, 08:24:05 AM »
Is it flashing orange or red ?.
I take it you have checked the oil level.

8
General X5 Forum (E53) / Re: Tow-bar
« on: June 21, 2017, 01:59:58 PM »
Tow-bar delivered this morning  :) :)

9
Problems / Re: Ac issue
« on: June 20, 2017, 10:07:52 AM »
Put the lats seven of your VIN number in here and find every part number you will ever need.
http://www.realoem.com/

10
General X5 Forum (E53) / Re: Tow-bar
« on: June 20, 2017, 08:21:50 AM »
They wouldn't have it that it would fit just refunded my money.
Bought one from PF Jones just hope it turns up for weekend (got my man on standby).

11
General X3 Forum (E83) / Re: insurance renewal
« on: June 20, 2017, 05:45:21 AM »
My daughter is with Go Skippy the name put's me off lol.

12
General X5 Forum (E53) / Re: Transmission failsafe
« on: June 19, 2017, 02:32:18 PM »
Does it make any difference if you put the car in neutral and try starting it. 

13
General X5 Forum (E53) / Re: Tow-bar
« on: June 19, 2017, 07:26:21 AM »
Thanks X5Sport
I will mention that to them as i think your are right.

14
General X5 Forum (E53) / Re: recall
« on: June 18, 2017, 06:54:27 PM »
Right   did you call the dealer and ask about the recall then.

15
General X5 Forum (E53) / Re: Tow-bar
« on: June 18, 2017, 06:50:04 PM »
Thanks for the reply's.
I ordered one and the company asked for my reg number then got back to me saying it didn't fit the sport as sports models had different bumpers might be on an e46 but i didn't think so on an e53.

Pages: [1] 2 3 4 5 6 ... 9