Welcome to Xdrivers
Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - marti

Pages: [1] 2 3 4 5 6 ... 8
1
Other Marques / Re: XDrive Gran Tourer
« on: July 14, 2018, 05:48:02 PM »
Good to hear your impressed, looks nice too, as for servicing that will be computerized :))

2
Problems / Re: Sat nav on my 2014 X5 has lost me
« on: July 14, 2018, 05:03:39 PM »
Its a computer....so give it a reboot, disconnect the battery for 20 minutes...neg lead off first and on last...

3
They look like ///M 400 style alloys, have them on my e46....

4
General X5 Forum (E53) / Re: Wide-screen head unit
« on: July 14, 2018, 02:32:14 PM »
There is no CD slot in the widescreen anyway, (CD's would still run from the 6 changer in the boot)...its a tape slot..so as you say retro fit a touch screen.

5
Problems / Re: Alarm going off randomly - E70 X5
« on: July 14, 2018, 02:27:54 PM »
Disconnect the battery for 20mins (minimum)...neg lead off 1st and back on first...may just reset it...worth a punt....
Back on last i think you meant to say.
Yes ...well spotted ;)

6
General X5 Forum (E53) / Re: Folding mirrors
« on: July 14, 2018, 02:25:40 PM »
Thats a micro switch....bend it to the correct position and a good spray of WD40

7
General X5 Forum (E53) / Re: Folding mirrors
« on: July 13, 2018, 06:59:27 PM »
I dont think your problem is the arm, from what you've said if that were the case the motor would be running all the time trying to force the mirror back....which doesn't make sense....are both sides doing it?,,if so...sounds more like a problem with the switch control button...the one you press to operate the mirrors sticking or its give up the ghost...hard to do but try to give it a blast with air from a can or WD40

8
Problems / Re: Alarm going off randomly - E70 X5
« on: July 13, 2018, 05:48:03 PM »
Disconnect the battery for 20mins (minimum)...neg lead off 1st and back on first...may just reset it...worth a punt....

9
General X5 Forum (E53) / Re: Wide-screen head unit
« on: July 13, 2018, 05:38:15 PM »
Okay here are your modules:
https://www.ebay.co.uk/sch/i.html?_odkw=bmw+e53+16.9+screen&_osacat=0&_from=R40&_trksid=m570.l1313&_nkw=bmw+e53+16.9+module&_sacat=0

As Greydog has pointed out you will also need the DVD drive:
https://www.ebay.co.uk/itm/Bmw-E39-E46-E53-Land-Rover-Sat-Nav-DVD-MK4-Head-Unit-6920182/292624794203?hash=item4421cc025b:g:vcEAAOSwhEla7zhW

The wide-screens are a mine field...you must get one from and e53 or you will have to start cutting the airducts to get the rear of the screen in and gaffer tape the the holes up...the e38 chaps have the same problem if they buy one for an e53...chop chop!

10
General X5 Forum (E53) / Re: Range 620
« on: July 13, 2018, 04:17:51 PM »
The actual tank range as specified by BMW is 593miles....for an automatic.

11
General X5 Forum (E70) / Re: Wing mirror protector/guard
« on: July 12, 2018, 03:59:42 PM »
Try ECP or ebay.

12
General X5 Forum (F15) / Re: Ad blue
« on: July 12, 2018, 03:28:11 PM »
You can get AdBlue deleted.....

13
Problems / Re: CAR RADIO
« on: July 11, 2018, 06:10:48 PM »
Disconnect the battery for 20mins (min) negative lead off and on last...it might just re-set it....if not reply back and I'll rack my brains...

14
General X5 Forum (E53) / Re: Wide-screen head unit
« on: July 11, 2018, 06:08:21 PM »
Yes, but you have to get one from and X5 (with the bezel) and not the e38 (7) or e39 (5), you will also need the module in the boot the galvanized box with the blue and white connector.

15
General X3 Forum (E83) / Re: Engine Noise?!
« on: July 02, 2018, 06:13:24 PM »
That is unusual for 57k engine to have that problem, possibly one has just broken due to a manufacturing fault, get a metal tube and place it on the chain cover and put your ear the other end and listen...I use that method when trying to locate strange noises on engines...its worked for me on many things....

Pages: [1] 2 3 4 5 6 ... 8