Welcome to Xdrivers
Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Flinders

Pages: [1] 2 3
1
Problems / Re: Gearbox issue? Lurches when changing up from 2nd to 3rd?
« on: September 13, 2018, 10:52:38 PM »
Sorry to hear your problems Flinders. I have the knowledge base of a gnat but I did have an E60 3.od that had that problem after it was mapped. The garage corrected it by resetting the gearbox with some sort of ignition key turning sequence after which you drive the car in a normal manner of acceleration so that the gearbox can learn its moves again but more smoothly.
This sounds a load of tosh to me as I'm typing it but it did correct the problem.
Can anyone else on here explain this better?

Thank you Moggyboy this sounds like it could be what I need to do. It’s hardly done it today as yesterday I drove it in sport as I’d read on here someone had done, this morning it didn’t do it and I drove home like a nun tonight.... and it didn’t do it! Lol! I think it needs to relearn my driving and if I drive slowly rather than the speedy thrashing I normally drive then it might sort it!

Does anyone know the procedure for the resetting of the gearbox?

2
Problems / Re: Gearbox issue? Lurches when changing up from 2nd to 3rd?
« on: September 12, 2018, 09:47:27 PM »
Thanks StuBeeDoo we have had the oils etc changed at BMW when we bought the car nearly 16 months ago. It’s just got worse since the service, battery replacement and tyres. All these were at same time so I can’t pin point any one thing that could have brought it on. I had wondered f the battery change means the gearbox has to relearn my driving style?

3
Problems / Gearbox issue? Lurches when changing up from 2nd to 3rd?
« on: September 12, 2018, 09:19:39 PM »
I now have a problem with gear changes. There is a lurch between gear change upwards, under load from 2nd tom3rd gear. It does it whether I am in drive, sport or manual mode.

Car has been through the mill this past 2 weeks from flat battery after changing light bulbs to worm tyres on rear on insides to the wire!  :o. Now since having service, battery change and tyres replaced on rear (* rated but offset set up) we now have the terrible lurch which is like a learner drivers gear change! Just in the change from 2nd to 3rd no other gears.

It did do this to a lesser extent before the service, battery and tyres lark and has always been a bit of a poor gear change but now this is really noticeable.... and annoying!

It’s a 59 plate 35d with 71k on the clock. Hopefully this is just a short term run of problems rather than the start of many to come!

Also do I need to have a timing belt or anything changed on the X6?


4
Problems / Re: Changed Front Dip Bulb and now X6 won’t start!
« on: August 27, 2018, 11:00:03 PM »
Thanks X5Sport for useful advice. It was a flat battery! I’ve had Green Flag out and they got me started so been driving round to get some charge into it. We are booked in for a service 1 Sept so I will get a new battery fitted as can’t risk this happening again.

I’d not left the door open or lights on but had done a short start and stop to check the lights as changed both lights. It was after the second bulb fitting it wouldn’t start.

Come to think of it last winter it would loose its times and turn the stereo off by time I got in it every morning so maybe the battery was on its way out?

5
Problems / Changed Front Dip Bulb and now X6 won’t start!
« on: August 27, 2018, 08:20:07 PM »
 :o
Just changed the front drivers side dip bulb and went to start X6 to check bulb working and now it won’t start! Lights on dash come on as normal just won’t crank when I press start button. It was working perfectly before bulb change and no problems with starting it 15 minutes earlier. Is there an anti theft on it that could have been activated or something? If so how do I get the anti theft off?! Typical bank holiday Monday problems! Doh!

6
General X6 Discussion / Re: Vehicle Recall
« on: July 01, 2018, 09:59:23 PM »
Ok thanks looks like mines not affected by the recall then.  :)

7
General X6 Discussion / Re: HID Dipped Beam Bulb Replacement
« on: July 01, 2018, 09:27:36 PM »
Thank you. Looks like the sram night breaker the best option. I had seen some on eBay that were £19.99 for a pair but these were a brand I've never seen before so I will steer clear then!

I seem to be having a run of bulb problems at the moment!

8
General X6 Discussion / HID Dipped Beam Bulb Replacement
« on: June 30, 2018, 04:39:49 PM »
X6 59 plate 35d. One of my dipped lights has stopped working so Im looking at replacements. Can anyone recommend a brand or k which gives a real good look and also good visability?

Do you have to replace them in pairs as I had to do with my Audi? Have checked price on Halfords and they are £51 each. I think the bulb I need is the D1S.

9
General X6 Discussion / Re: Vehicle Recall
« on: June 30, 2018, 04:34:37 PM »
Which year of X6 does this recall affect? Not had anything regarding a recall and only just seen this now. Mine is a 59 plate 35d.

10
It’s not working on the right side but works on the left. Could it be a fuse? There’s no wet or corrosion in the area so not sure how to check that?
 

11
Problems / Reverse light failing despite changing the bulb......?
« on: April 25, 2018, 09:24:07 PM »
I’ve had the reverse light fail warning on my heads up for a few days now so went for replacement bulb today and replaced it this afternoon. The message still says reverse light failure at the same side despite changing. What else could this be? Hope this doesn’t mean a complete new light unit!

Has anyone else had this issue? It’s a 3.0 35d 59 plate x6 with 65k on the clock.

12
Problems / Re: Engine just cuts out.....
« on: September 27, 2017, 08:14:06 PM »
For future info if anyone has symptoms like this with no engine management light and not going into limp mode it could be the injectors. Our injectors 2 and 5 have failed and it’s now in the garage being repaired  :(

13
Problems / Engine just cuts out.....
« on: September 25, 2017, 08:13:30 PM »
I have a 3.0 59 plate 35d and a problem that started yesterday. I had the engine tick over for about 20 mins while stationary then went to set off and the engine cut out and we just rolled forward to a pull in place. Tried to restart but it just kept turning over. To stop this I had to put foot brake on, take key in and out and then restart engine and it would start and was fine.

It’s done it again tonight but we were only at standstill for 5 mins then engine cut out again and has been getting worse the further I drove trying to get home. It seemed to be when tried to accelaerate? Would just jerk a little then engine would stop. No noise or knocking or banging. Manage to get it home but there are no warnings from dash or other signs of why it’s doing this? Drove home from work and to work fine this morning and tonight but later when out it started this again?

Not sure if DPF or EGR valve as usually this would bring an engine management warning up on dash and would be able to drive in limp mode in my Audi so not sure what or how it warns you or limp mode in the BMW X6?

It’s certainly not safe to drive on the motorway as it just cuts out so if to get to garage in Leeds it will need transporting by Rescue? Anyone experienced anything like this before? Cheers.

14
General X6 Discussion / Re: Sat nav upgrade
« on: June 23, 2017, 01:04:07 PM »
Thanks X5Sport. Certainly not worth the extra money then. We should have waited and got a 2010 X6. Looks like I will just have to replace the disc that is slightly scratched. The DVD player works fine as we have had that checked out by BMW but to replace the disc the ones I have seen on ebay are £50 odd pound! .....Will just turn my music up louder to block out the wurring noise! Got to admit my Audi was far better built than the X6 :(

15
Thank you Horizon. I won't waste my money on them then :-)

Pages: [1] 2 3