Strange electrical problem, help needed. - Now sorted.

Discuss your latest mods or ideas, and anything to do with the X5 (E70).
paulrog
Newbie
Newbie
Posts: 26
Joined: Mon Jul 08, 2013 8:10 pm

Strange electrical problem, help needed. - Now sorted.

Fri Nov 02, 2018 8:24 pm

Hi,

Hi have a 2010 4.0D LCI X5 SE with a strange electrical problem.

Occasionally the Glovebox, Rear tailgate, Aircon (cold air stops coming out, everything else works) and windscreen washers (both front and rear) stops working, all at the same time,

It's so random that it can work one minute, then not the other.

Obviously it's an electrical fault, there seems to be a lose of power to all of these bits of equipment so i need to find something which controls all the systems, like a control module which could be failing?? or a common power supply fuse or cable??

No warning lights come on or idrive fault warnings.

If anyone has had this problem, or has any ideas please let me know.

Thanks.
Last edited by paulrog on Wed Jan 23, 2019 10:10 am, edited 1 time in total.
.
User avatar
X5Sport
Lifer
Lifer
Location: Planet X6......
Posts: 16331
Joined: Fri Sep 03, 2010 4:09 pm

Re: Strange electrical problem, help needed.

Fri Nov 02, 2018 9:06 pm

Not necessarily the issue but check....

Battery earth connection is tight at the battery.
Battery +ve cable is tight at the battery and under the bonnet at the jumper point.
Battery age and condition.  Aging batteries will cause the car to shutdown systems.
Any sign of damp in the fuse board.
Any sign of corrosion in the fuses.

It could be a bad earth behind the glovebox - there are a couple of ‘comb’ connectors behind the dash which if loose could cause connection loss.

Just a few things that spring to mind.  Others may chip in with places to look too.
:ant: Never anthropomorphise computers. They hate that.
Image
paulrog
Newbie
Newbie
Posts: 26
Joined: Mon Jul 08, 2013 8:10 pm

Re: Strange electrical problem, help needed.

Thu Dec 06, 2018 3:56 pm

Ok, i've replaced the battery with a like for like battery and coded it.

The fault still exists!!!!

So the things which don't work are -

Tailgate
Air con
Glove compartment.
Front & Rear windscreen washers.

The fault seems to be getting worse as these don't work now most of the time.

Really strange, checked all the fuses in the 2 fuseboxes and no problem, checked to see that all plugs are connected ok. checked all the connections near the battery and no signs of corrosion anywhere.

Anyone with any good ideas?? Before i finally take it to BMW.

Thanks.
User avatar
moggyboy
Member
Member
Posts: 91
Joined: Thu Jun 09, 2016 12:21 am

Re: Strange electrical problem, help needed.

Thu Dec 06, 2018 5:02 pm

This is a long shot but pull open the cover on the right side of the boot and check down in the cavity at the bottom underneath the fuse board to see if it has water in it.
Mine did some time ago and corroded the copper wires causing all sorts of erroneous messages and faults.

Hope this helps.
paulrog
Newbie
Newbie
Posts: 26
Joined: Mon Jul 08, 2013 8:10 pm

Re: Strange electrical problem, help needed.

Fri Dec 07, 2018 4:17 pm

Thanks for your help, unfortunately i found no sign of water at the bottom of the boot or anything corroded.

Still no joy, i'll have to book it in the BMW soon to repair the fault.

I've Googled the issue but can't find anything which points to the problem, I thought maybe a faulty

module, but i ran carly and no specific fault codes came up for the issues i'm getting???
paulrog
Newbie
Newbie
Posts: 26
Joined: Mon Jul 08, 2013 8:10 pm

Re: Strange electrical problem, help needed. - Now sorted.

Wed Jan 23, 2019 10:23 am

Just for anyone who starts getting weird problems with the electrical systems on the car, I've finally found the fault and everything now works.

So after i checked the fuses and then replaced the battery which made no difference, I looked for any fault codes, that was a positive step as there were a few codes that pointed to my problems, now as all the problems are connected because they are either all working or all not working I started looking for a common connection, and i found the electronic module which provides the power to all of them is called the Electronic Junction box which is located in the passenger footwell just next to the fusebox.

This Electronic Junction Box is a central part of the car's electrical system, there is a long list of equipment that it controls and powers.

So i took it to BMW, I talked to the technician about what i thought and after a couple of hours they diagnosed it and it was replaced and programmed up.

So it's all working now, it's an expensive repair £715, the cost of the box was only £300 but i had to pay for an hours fault diagnosis, cost of replacing then programming.
Leslie
Member
Member
Posts: 298
Joined: Sat Sep 29, 2018 10:58 am

Re: Strange electrical problem, help needed. - Now sorted.

Wed Jan 23, 2019 11:10 am

Thanks for posting back sometimes you just have to pay the dealer as no one else can sort it although it sounds like you did the hard work but few parts seems to be plug and play anymore ! I'm sure you are glad its sorted anyway :D
User avatar
moggyboy
Member
Member
Posts: 91
Joined: Thu Jun 09, 2016 12:21 am

Re: Strange electrical problem, help needed. - Now sorted.

Wed Jan 23, 2019 11:40 am

I'm glad you've got it sorted but ouch with the price.

Return to “General X5 Forum (E70)”