X5 E70 EGR - Puzzled

Discuss your latest mods or ideas, and anything to do with the X5 (E70).
PierreNel1982
Newbie
Newbie
Location: London
Posts: 39
Joined: Tue Jan 16, 2018 4:05 pm

X5 E70 EGR - Puzzled

Wed Nov 28, 2018 12:17 pm

Hi Guys. I have been on here before with an random power loss issue to begin with ages ago (Feels like limp home more, with no EML). Traced it down to when I disconnect the EGR valve from the vacuum feed, the car returns to full power.

I checked the EGR valve, it was clean and springs closed immediately on testing. My test was physically pushing it open from the exhaust input side, was very stiff and not easy to open or keep open.

I have changed to EGR Vacuum solenoid twice now. I did notice the 1st time I changed it that it was connected in reverse vs REALOEM. IE the vacuum input from the vacuum line and output to the EGR valve were the opposite. This was after my Indi has replaced the Glow plug controller. I connected it up as I had found it (incorrectly) the same issue persisted upon testing. I then connected it up as per RealOEM. No change again. I then thought that connecting the solenoid in reverse to begin with had damaged it, so I bought another 1. Connected it up correctly to begin with and still the same issue persisted, tried in reverse and the car still feels the same. I will admit my parts were off ebay (unbranded), so should I get a Pieburg solenoid or is there something else I should look at in fixing this weird problem?

Thanks
User avatar
Alan Gunn
Member
Member
Location: Anglesey North Wales
Posts: 711
Joined: Thu Dec 08, 2016 10:32 pm

Re: X5 E70 EGR - Puzzled

Wed Nov 28, 2018 12:47 pm

I would try a second hand EGR .
My car is not the same but the power is the same with it connected or not.
Can you feel any suction on the pipe when you pull it off the egr if you get what i am saying.
PierreNel1982
Newbie
Newbie
Location: London
Posts: 39
Joined: Tue Jan 16, 2018 4:05 pm

Re: X5 E70 EGR - Puzzled

Wed Nov 28, 2018 1:16 pm

Thanks Alan.
I want to 1st get a vacuum tester kit. But I want to know what to test for.
When should the vacuum shut off to close the EGR valve.
Does it happen the instant you apply the throttle or is it progressive to a point then closed?

Im getting a constant vacuum from the solenoid irrespective of throttle position. It cant be the ECU thats somehow gone wrong and sending the wrong signal to open? I havent had any remaps, tuning done to this car. Ran fine for nearly a year after purchasing.

I have had this issue for nearly a year!
Been driving with it disconnected, but the EML light driving me nuts now.
User avatar
Alan Gunn
Member
Member
Location: Anglesey North Wales
Posts: 711
Joined: Thu Dec 08, 2016 10:32 pm

Re: X5 E70 EGR - Puzzled

Wed Nov 28, 2018 4:03 pm

I think the EGR should be closed when the engine is ticking over.
When the engine is off it should be closed as well.
Pat Mustard
Member
Member
Posts: 63
Joined: Tue Dec 05, 2017 5:23 pm

Re: X5 E70 EGR - Puzzled

Wed Nov 28, 2018 7:25 pm

One thing comes to mind. You said your indi changed the glow plug controller recently. You need to follow the 2 vacuum lines that run over the top of the controller because I have seen it more than once that when the new relay is fitted one of the vacuum lines slips down and gets piched under the relay itself thus creating an egr fault. Very simple thing to happen accidentally.
PierreNel1982
Newbie
Newbie
Location: London
Posts: 39
Joined: Tue Jan 16, 2018 4:05 pm

Re: X5 E70 EGR - Puzzled

Thu Jan 03, 2019 4:02 pm

Thanks Pat.

I have ordered a used BMW EGR solenoid. My previous part was from online but quality might be off possibly. Feel like such a wally throwing the original away, might have been ok to begin with.
I will also check the vacuum lines to ensure they are not pinched.
PierreNel1982
Newbie
Newbie
Location: London
Posts: 39
Joined: Tue Jan 16, 2018 4:05 pm

Re: X5 E70 EGR - Puzzled

Thu Jan 03, 2019 5:15 pm

I need help here.
Looking carefully at this diagram, my car only has part 01,02,03,07 & 08
Pipe 02 connects to the solenoid , part 01(solenoid), which connects to the diaphragm with a short pipe (not mentioned here) which moves the swirl flaps arm.
There is no 2nd (greyed out 4) pipe and the circled 6 is confusing me, as my car does not seem to have these/this parts.

Can anyone inform me of how my car should be connected up? Am I missing something, did my indi lose something when changing the glow plug controller
Think this could be the cause of my EGR issues, as it could be causing the vacuum to be incorrect in some way. My idle is also a little rough these days it seems, even though I put injector cleaner through recently.

Thanks
Attachments
Diagramme.JPG
Diagramme.JPG (55.4 KiB) Viewed 137 times
PierreNel1982
Newbie
Newbie
Location: London
Posts: 39
Joined: Tue Jan 16, 2018 4:05 pm

Re: X5 E70 EGR - Puzzled

Mon Jan 07, 2019 1:28 pm

Update: Had a look at the vacuum pipes and none were pinched or damaged.
I replaced the solenoid with a used BMW part, and presto the car runs fine. All issues gone and no warning lights.
Im gobsmacked....bought two solenoids online from two different sites and they didnt work....
how can that be?

in the end, the 3rd solenoid cost me £10!!!

Return to “General X5 Forum (E70)”