Bluetooth won't pair

Discuss the problems with your X5 (E53).
Bennn
Newbie
Newbie
Posts: 33
Joined: Sun Dec 02, 2018 8:17 pm

Bluetooth won't pair

Sat Jan 19, 2019 5:13 pm

Hi guys. Having an issue in that my Bluetooth won't pair.

I press the button for 3 seconds then switch on ignition and the lights don't display and it doesnt get to pairing. The display if i select bluetooth says activate phone.

I'm holding the button down after for a few seconds (have tried holding longer with no joy) is have tried holding longer than 3 seconds before putting the ignition on.

I've pulled the back off the arm rest and the wiring looks intact and ok and I've tried resetting the module by taking out fuses for the nav unit and turning on and off again without luck either.

Anyone got any ideas what I can try next?

Tempted to get an android head unit instead as the sat nav will be better I can use Bluetooth streaming etc but I like how the standard unit link up to the dash.
User avatar
X5Sport
Lifer
Lifer
Location: Planet X6......
Posts: 16219
Joined: Fri Sep 03, 2010 4:09 pm

Re: Bluetooth won't pair

Sat Jan 19, 2019 6:01 pm

Do you know which version you have? There are two built in versions which only pair to the correct OEM handsets (Motorola or Siemens), or a system that will pair with other phones from that era (or modern phones supporting early versions of Bluetooth).

Also have you checked the module is in the boot? Left side cubby tucked in at the bottom if memory serves. They aren’t the most reliable modules and many owners have suffered failures. It isn’t unknown for failed modules to have been removed. If there are no lights then it sounds like a bad module.

There are something like 14 different versions (yes BMW got it that wrong) with only the very last version being any good. They are plug and play if you can still get them. Check Realoem for the last issued variant part number.
:ant: Never anthropomorphise computers. They hate that.
Image
User avatar
marti
Member
Member
Location: Norfolk
Posts: 335
Joined: Tue Jan 19, 2016 11:33 am

Re: Bluetooth won't pair

Sun Jan 20, 2019 11:36 am

Never had a problem with my X5...paired up iphone and samsung without any bother.....
Bennn
Newbie
Newbie
Posts: 33
Joined: Sun Dec 02, 2018 8:17 pm

Re: Bluetooth won't pair

Sun Jan 20, 2019 3:37 pm

X5Sport wrote:
Sat Jan 19, 2019 6:01 pm
Do you know which version you have? There are two built in versions which only pair to the correct OEM handsets (Motorola or Siemens), or a system that will pair with other phones from that era (or modern phones supporting early versions of Bluetooth).

Also have you checked the module is in the boot? Left side cubby tucked in at the bottom if memory serves. They aren’t the most reliable modules and many owners have suffered failures. It isn’t unknown for failed modules to have been removed. If there are no lights then it sounds like a bad module.

There are something like 14 different versions (yes BMW got it that wrong) with only the very last version being any good. They are plug and play if you can still get them. Check Realoem for the last issued variant part number.
Thanks. Is this module? It is an 05 car so should be one of the more recent ones. I was able to connect my iPhone up to the one in my 2004 330ci so would have thought it would work with this car too?

Image

Have seen a few second hand ones on ebay, would these fit? And would it need coding?

Image

Return to “Problems”