rear wiper sluggish

Discuss your latest mods or ideas, and anything to do with the X5 (E53).
Smeeagain
Snr Member
Snr Member
Posts: 1850
Joined: Thu Aug 12, 2010 7:14 pm

rear wiper sluggish

Mon Aug 12, 2019 9:36 am

Has anyone had this issue - my rear wiper motor appears to be sluggish - really slow across the rear screen often stopping at the halfway mark. I took the wiper arm off and cleared out all the crap etc and cleaned the glass with polish (to reduce surface tension). It helped a bit but it is not great.

Anyone had this problem - I assume the wiper motor is on the way out but anted to check and see if it was something simple before doing that?

Smee
User avatar
marti
Member
Member
Location: Norfolk
Posts: 490
Joined: Tue Jan 19, 2016 11:33 am

Re: rear wiper sluggish

Mon Aug 12, 2019 4:27 pm

As youve said motor on its way out.
weirdfish
Member
Member
Location: Glos.
Posts: 587
Joined: Fri Apr 01, 2011 7:10 pm

Re: rear wiper sluggish

Mon Aug 12, 2019 6:38 pm

Motors either work or don't, I would think it's something like a partially seized drive shaft from the motor to the actual wiper arm itself.
Strip down as much as you can and give it a good clean, lubricate and re-assemble.
Might be just as bad, but at least it's cost you jack shit to try.
Themoog2
Member
Member
Posts: 89
Joined: Sun Nov 25, 2018 10:29 pm

Re: rear wiper sluggish

Thu Aug 15, 2019 5:50 am

Nah. Same happened to mine a few years ago. I did all the cleaning etc to no avail so in the end I just swapped the motor.

Return to “General X5 Forum (E53) ”