Welcome to Xdrivers
Please login or register.

Author Topic: What am i doing wrong with my Aircon settings ???  (Read 394 times)

0 Members and 1 Guest are viewing this topic.

April 18, 2017, 10:04:48 AM

RickUK

  • Member
  • **
  • Posts: 70
  • Country: gb
  • Location: Not sure me Tom Tom is bust.
  • Gender: Male
    • View Profile
    • Our Germain Shorthaired Pointer.
What am i doing wrong with my Aircon settings ???
« on: April 18, 2017, 10:04:48 AM »
Require some help/advice on what i am doing wrong in setting up the Aircon on my 56plate 3ltr diesel X5,this has too be operator error i would think rather than a faulty unit,but like most things in life anything could be wrong.

As i understand it when i want to use the Aircon i reduce the temperature on both the drivers and passengers side as low as possible which in my case its lowest position is 60f which i have just checked and it equates to 15.5 c if i am correct,so the temperature on the scale is as low as it will go on both sides.

Then am i right in saying one hits the snowflake or what ever it is button which i assume is the main aircon switch,then hit the Auto button and then slide the fan speed up,it does blow cold air but not as cold as what i would have thought it would be.

Of course it could need re-gassing but as i understand it was done about a year ago,and had no problems just done because the previous owner was fastidious about the car.

So could anyone please help guide me on what i am doing wrong,it must be the settings or i am overlooking something,but as usual its odds on favourite 'operator error'

Many thanks
2006 '56 BMW X5 D M SPORT LE-MANS EDITION

April 18, 2017, 10:21:36 AM
Reply #1

X5Sport

  • Lifer
  • *****
  • Posts: 14363
  • Country: england
  • Location: Planet X6......
  • Gender: Male
  • Über Geek in Chief
    • View Profile
Re: What am i doing wrong with my Aircon settings ???
« Reply #1 on: April 18, 2017, 10:21:36 AM »
16°C is the normal low point if in metric so 60°F is roughly the same.  Sounds like you are doing everything right.

The 'snowflake' does indeed turn the compressor on and Auto will then run the climate control at that setting.  You also need the thumbwheel in the front vents set to neutral (neither hot nor cold) as it runs differently to the main climate and you can set it colder or hotter.

If you don't run the compressor at least once per month then the seals dry out and you will lose gas.  Typical 'in use' loss is up to 15% per year when brand new so it will be higher now.

Could well be that the gas loss is high and it needs a refill again, especially if not left running all the time.  I never turn mine off and on my E53 it needed a regas at about 4 years old. 

Check for a 'click' from under the bonnet which will tell you the compressor clutch has engaged.  No click means there isn't enough pressure in the system and it locks out. 

Also check that the electric fan starts when the a/c is selected.  No fan also means there is a problem (fans are known to fail).
:type:

April 18, 2017, 10:22:17 AM
Reply #2

Alan Gunn

  • Member
  • ***
  • Posts: 124
  • Country: wales
  • Location: Anglesey North Wales
  • Gender: Male
    • View Profile
Re: What am i doing wrong with my Aircon settings ???
« Reply #2 on: April 18, 2017, 10:22:17 AM »
Does your car have the wheel with red and blue bars in the centre air vent(mine has but older car).
If it has turn it all the way round on the blue side if you know what i am saying.
If that has no effect then get the gas level tested.

April 18, 2017, 11:07:26 AM
Reply #3

RickUK

  • Member
  • **
  • Posts: 70
  • Country: gb
  • Location: Not sure me Tom Tom is bust.
  • Gender: Male
    • View Profile
    • Our Germain Shorthaired Pointer.
Re: What am i doing wrong with my Aircon settings ???
« Reply #3 on: April 18, 2017, 11:07:26 AM »
Its Bingo time  :) i almost had it set right,but 'duh' forgot too open those vents into the blue area,and then it worked as it should do,infact i had to go inside and put my coat on it was that cold  :)) :)) but glad that it was nothing major.Usually when things like this happen and the car has been fully serviced etc from new its 'operator error'.

Anyway would like to thank you all for the help/advice/suggestions it worked a treat  ;)
2006 '56 BMW X5 D M SPORT LE-MANS EDITION

June 19, 2017, 07:06:35 PM
Reply #4

RickUK

  • Member
  • **
  • Posts: 70
  • Country: gb
  • Location: Not sure me Tom Tom is bust.
  • Gender: Male
    • View Profile
    • Our Germain Shorthaired Pointer.
Re: What am i doing wrong with my Aircon settings ???
« Reply #4 on: June 19, 2017, 07:06:35 PM »
The Aircon decided to start blowing warm air on the hottest week of the year thus far,finally took it into a local service center and they re-gassed the system for me,it was very low and they also added oil or what ever they do so that the oil seals dont leak.

Verdict on what the result are like,its that bloody cold i think i would need a coat to keep me warm.Very impressed with the results.
2006 '56 BMW X5 D M SPORT LE-MANS EDITION

June 19, 2017, 07:40:49 PM
Reply #5

X5Sport

  • Lifer
  • *****
  • Posts: 14363
  • Country: england
  • Location: Planet X6......
  • Gender: Male
  • Über Geek in Chief
    • View Profile
Re: What am i doing wrong with my Aircon settings ???
« Reply #5 on: June 19, 2017, 07:40:49 PM »
It was 33°C driving back this afternoon and I'm very glad to have climate control.  I just need to find a way to get it to cool the house down now......and tother half didn't find my suggestion of parking it in the lounge with the windows open and hoses connected to the exhaust acceptable!  I even told she could still watch telly  O:-)
:type:

June 22, 2017, 02:17:44 PM
Reply #6

marinaman

  • Member
  • **
  • Posts: 88
  • Country: gb
  • Gender: Male
    • View Profile
    • extra sausage for members :)
Re: What am i doing wrong with my Aircon settings ???
« Reply #6 on: June 22, 2017, 02:17:44 PM »
wonder if i have my setting right as well,  if i get in car from red hot day outside and the car is boiling hot should it not automatically blow the max amount of cold air  like it does when you press the button MAX.   mine doesnt unless i have set it wrong.
B&B by the sea in sunny Bridlington, best rates for members  :) www.themarina-bridlington.com

June 22, 2017, 05:40:50 PM
Reply #7

X5Sport

  • Lifer
  • *****
  • Posts: 14363
  • Country: england
  • Location: Planet X6......
  • Gender: Male
  • Über Geek in Chief
    • View Profile
Re: What am i doing wrong with my Aircon settings ???
« Reply #7 on: June 22, 2017, 05:40:50 PM »
Set it to 'Auto' and have the snowflake symbol on (ac compressor) and the upper front air vent control set to its middle mark (between hot & cold).  That vent overrides the ac setting.

If you turn the ac on is there a 'click' and does the temperature drop to 16°C on Auto?  If neither then you may have lost gas.  The Aux fan should also come on.
:type:

June 23, 2017, 07:30:33 PM
Reply #8

marinaman

  • Member
  • **
  • Posts: 88
  • Country: gb
  • Gender: Male
    • View Profile
    • extra sausage for members :)
Re: What am i doing wrong with my Aircon settings ???
« Reply #8 on: June 23, 2017, 07:30:33 PM »
Yes  it clicks on auto if i press max. and drops to 16
if i set it at 20 and get in on a red hot day i think i was expecting it to drop to 16 and the max setting come into operation.   is this right or wrong ? 
B&B by the sea in sunny Bridlington, best rates for members  :) www.themarina-bridlington.com

June 24, 2017, 11:30:02 AM
Reply #9

X5Sport

  • Lifer
  • *****
  • Posts: 14363
  • Country: england
  • Location: Planet X6......
  • Gender: Male
  • Über Geek in Chief
    • View Profile
Re: What am i doing wrong with my Aircon settings ???
« Reply #9 on: June 24, 2017, 11:30:02 AM »
No it sits where you set it.  If you want 16°C you have to set it there.  The fans should come on to clear the hot air, but it will aim for the set temperature and not below.  All my 'climate control' equipped BMWs have worked this way and so does my Škoda but it may be different on AC only equipped cars.
:type: