Welcome to Xdrivers
Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Silverfox58

Pages: [1] 2 3
1
General X5 Forum (E53) / Folding mirrors
« on: July 13, 2018, 06:52:13 PM »
Hi all
My mirrors fold in but don't stay there, I have taken the microswitch out and the arm was flat , I've seen on YouTube that it has
A fold in it, can I buy one of them or I will have to try and bend it, what else stops the mirrors from folding back.

2
Performance / Engine size
« on: June 29, 2018, 01:59:06 PM »
Hi just trying to order some parts for my x5 e53 30d and I need to know if it's a 184hp or 211hp or 218hp  my engine number  is 
27046012
Any ideas

3
General X5 Forum (E53) / Brakes
« on: May 11, 2018, 07:11:39 PM »
Hi all
Any thoughts on this,
 my brake peddle go's  hard when trying to brake but not all the time,

4
General X5 Forum (E53) / Whine from front question
« on: April 21, 2018, 07:06:33 PM »
Hi all
I have a whine from the front above 50mph , now could this bearing or diff ,could take the fuse out for the 4x4 to check
The front diff ????
Any advice please

5
General X5 Forum (E53) / Folding mirrors
« on: April 18, 2018, 06:34:37 PM »
Hi all is there a how to to fix folding mirrors that's not on photobucket

6
How-To / Folding mirrors
« on: April 18, 2018, 06:16:14 PM »
Hi all is there a how to to fix folding mirrors that's not on photobucket.

7
General X5 Forum (E53) / Rear suspension
« on: April 02, 2018, 05:21:25 PM »
Hi all
What to the dump yesterday with a load of wood in the car , loaded car but when I started the car the air suspension failure message came on , when to the dump and got rid of the wood , started  car and no warnings,  and hasn't came on again,
Now my question is do I have a rear suspension problem or was there to much weight in the car ???
The drives ok with no problems it's not down on one side , as it's done 125k could the bags be soft and need changing.
Your thoughts please

8
General X5 Forum (E53) / Car won't start
« on: March 21, 2018, 11:47:55 AM »
Car won't start just get lots  of white smoke it try but not having it
Any ideas

9
General X5 Forum (E53) / HELP PLEASE
« on: March 17, 2018, 09:53:43 AM »
Hi all just fitted new glow plugs and a new manifold all went well with no problems,
But now I can't  start the car , I have cleared all faults but still won't start ,
Can you advise please  >:( >:( >:(

10
General X5 Forum (E53) / Smoke in cab when starting
« on: March 01, 2018, 06:19:48 PM »
Hi all
Recently with all the snow when I start the car I get a lot of exhaust smoke in side the car , is this right or what should
I look out for.
Your thoughts please

11
General X5 Forum (E53) / Radio not working
« on: February 09, 2018, 03:39:16 PM »
Hi all just fitted a new head unit factory bmw one but all i get
Is the screen comes on and then gos out but thats it none
Of the buttons work >:( do i have to reset it or something
HELP PLEASE

12
Buy and sell / 19"wheels. NOW SOLD
« on: January 14, 2018, 09:13:17 AM »
Hi all i have a set of x5 19"wheels if anyone wants them
Before they go on ebay £200
Pick up kent9

13
General X5 Forum (E53) / E53 stereo
« on: January 06, 2018, 05:53:51 PM »
Hi  can the stereo in my 55 plate x5  be repaired if so do you know anyone who dose it , or anyone  have a decent one for sale

14
Buy and sell / Wanted e53 stereo
« on: January 06, 2018, 05:39:55 PM »
Hi all anyone  have a good stereo for a 2055 e53 for sale

Or can they be repaired

15
Problems / Starting
« on: December 09, 2017, 12:29:04 PM »
Hi all
I have recently replaced my glow plug controller not the plugs, it was starting ok before but as the cold weather was approaching I thought I  would start there as the light wasn't coming on on the dash, all good now, but when I start the car now it seems to splutter and I get a lot of smoke, question do I have A injector or two peeking or could it be something else and how do I check them, ie do a leek test would that show up the problem, all so do I have a cold start valve ??

Pages: [1] 2 3