Welcome to Xdrivers
Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - H4MP

Pages: [1]
1
General X5 Forum (E70) / Re: X5 e70 Aircon nightmare help needed
« on: July 15, 2018, 09:02:08 AM »
Yea it can't be that I've fitted 2nd compressor. First a uses part it's more and more looking like an expansion valve stuck open as the compressor is engaging there are no leaks. Only thing is fan doesn't work so I'm having a new fan fitted. Bloody expensive part though £580 plus vat.

2
General X5 Forum (E70) / Re: X5 e70 Aircon nightmare help needed
« on: July 14, 2018, 11:03:58 AM »
X5 SPORT your help will be appreciated.

3
General X5 Forum (E70) / Re: X5 e70 Aircon nightmare help needed
« on: July 13, 2018, 07:16:56 PM »
How common or rare is it for expansion valve. Thanks nigeyboy. The problem I'm getting is the compressor is kicking in but no increase in pressure on guage. I will see to the final state resistor would this show up on a diagnostic machine

4
General X5 Forum (E70) / Re: X5 e70 Aircon nightmare help needed
« on: July 12, 2018, 08:16:52 PM »
Thanks nigey only think is my heating and fans work fine just not getting cold air

5
General X5 Forum (E70) / Re: X5 e70 Aircon nightmare help needed
« on: July 12, 2018, 07:03:15 PM »
The blowers still work. The compressor engages it's brand new but no change in pressure. Also the fan is not working there is plenty of gas. Could it be expansion valve stuck open. No cold air whatsoever no change In gas pressure on the low pressure side

Have you changed the “hedgehog?”

It’s the final stage resistor. Up behind the dash. I’ve had 2 fail, one in the E70 & one on an E53. The air con has a mind of its own when they’re faulty. Common fault on BMW & new cars.

About £50 if IIRC.

Nige.

6
General X5 Forum (E70) / Re: X5 e70 Aircon nightmare help needed
« on: July 12, 2018, 05:23:03 PM »
Where is the final stage resistor located? Also do you think it could be the expansion valve stuck open?

7
Newbies section / Re: Newbie looking for advice
« on: July 12, 2018, 02:25:15 AM »
Any luck I have the same car and same problem an oil leak. Previous owner has removed the dpf

Hi all, I'm new to this site and looking for a bit of help.
Having owned an E30 325i Cabriolet in the mid 90's I returned to the BMW fold earlier this year by buying a '08 X5 35d MSport with just about every extra on it - absolutely love it.  Looks - Power - Comfort
Unfortunately its developed 2 issues. One is that on hard acceleration black smoke comes out of the exhausts. Because the car is white this leaves a black residue on the back bumper. I have noticed a small oil leak from underneath the engine so think the two may be connected. I am booking it into my local garage soon so will update all with what the diagnosis is. However my other issue is that the blower on the drivers side won't blow hot air - the passgener side works fine. I've searched the site for help with this and it all seems to point to thermostat issues - however would this just affect the drivers side and not the passengers? any help would be greatly apprecaietd - thanks

8
General X5 Forum (E70) / Re: X5 e70 Aircon nightmare help needed
« on: July 12, 2018, 01:46:41 AM »
If that didn't make sense basically I've changed the compressor twice, there are no leaks. The clutch is engaging however no change in pressure on gas gauge. Also the aux or engine fan does not work. Really confused as I've had compressor and drier changed including pressure sensor

9
General X5 Forum (E70) / X5 e70 Aircon nightmare help needed
« on: July 12, 2018, 01:44:46 AM »
Originally Aircon wasn't working so regassed still didn't work. Was told it is compressor so has this changed with a 2nd hand one. Worked for 5 days blowing ice cold and then suddenly no cold air. The compressor clutch was engaging. So went to another specialist they made me change pressure sensor. Still did not work. Eventually was told compressor has internally failed so purchase a new Hella one. Changed compressor and fitted drier also today but still not blowing cold the clutch is engaging. Only other thing is the radiator fan does not kick in. If anyone can please help literally pulling hair out with this problem and I've spent over £1000 still no Aircon

Pages: [1]